Warning! LCN-Pro 4.82

Version 4.82 of the LCN-Pro will not program LCN through DOMIQ/Base modules.


In the latest release of the LCN-Pro software, 4.82, the Issendorff company disabled option to use PCHK 1.0 protocol which is used for remote programming of the LCN installations through the DOMIQ/Base. As a result, such programming is impossible with this and possibly later versions.

Our recommendation to all of our Customers is to postpone installation of the LCN-Pro 4.82 update.

We do plan to support PCHK 2.0 protocol with later software updates.

UPDATE: PCHK 2.0 is now supported starting with release 1.8.3.0

Sign in to comment